Canu not running


#1

Is anyone else having any problems with canu? Trying to run it on a gvl instance at warwick. But using the command:

canu -p JCT0052 -d ./canu genomeSize=2.5m -nanopore-raw ./porechop/BC01.fastq

I get the following:

– Parameters:

– genomeSize 2500000

– Overlap Generation Limits:
– corOvlErrorRate 0.3200 ( 32.00%)
– obtOvlErrorRate 0.1440 ( 14.40%)
– utgOvlErrorRate 0.1440 ( 14.40%)

– Overlap Processing Limits:
– corErrorRate 0.5000 ( 50.00%)
– obtErrorRate 0.1440 ( 14.40%)
– utgErrorRate 0.1440 ( 14.40%)
– cnsErrorRate 0.1920 ( 19.20%)

– Starting command on Tue Jul 10 22:54:04 2018 with 1683.823 GB free disk space

cd /home/ubuntu/Biofilm/Assemblies/barcode01/canu
sbatch \
  --mem-per-cpu=8g \
  --cpus-per-task=1   \
  -D `pwd` \
  -J 'canu_JCT0052' \
  -o canu-scripts/canu.01.out canu-scripts/canu.01.sh

Submitted batch job 14

– Finished on Tue Jul 10 22:54:04 2018 (lickety-split) with 1683.823 GB free disk space

and it finishes almost instantly. It creates a canu-logs and a canu-scripts directory in the output directory, but that’s it.


#2

Try forcing canu to run jobs locally, instead of using a job scheduler (which is the default). To disable the job-scheduling, you should be able to set useGrid=false as an argument. The command should look something like this:

canu -d canu -p JCT0052 genomeSize=2.5m useGrid=false -nanopore-raw porechop/BC01.fastq

From the manual:

    useGrid=string
      - Run under grid control (true), locally (false), or set up for grid control
        but don't submit any jobs (remote)

#3

Thanks Matt, that works.


#4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.