Corrupted files in volume [SOLVED]

before I try restoring a backup: could you please help me understand a problem with some files?
Many thanks, Andrea

Problem symptoms

When listing files on specific directories in a volume, metadata is replaced by ‘?’ and they can’t be read.


ls -l /bsb/16S/sandra/illumina/taxa/

ls: cannot access '/bsb/16S/sandra/illumina/taxa/taxonomy.qzv': Permission denied
ls: cannot access '/bsb/16S/sandra/illumina/taxa/taxonomy.qza': Permission denied
total 0
-????????? ? ? ? ?            ? taxonomy.qza
-????????? ? ? ? ?            ? taxonomy.qzv


The volume is bsb attached to tarp (/dev/vdb1) at Bham

If other files on the volume aren’t showing the same errors, this could be a permissions problem rather than a filesystem (corrupted files) problem.

Perhaps the owner of the /bsb/16S/sandra/illumina/taxa/ directory doesn’t have execute permission?

As the user that owns the directory, please could you:

sudo chmod u+x /bsb/16S/sandra/illumina/taxa/

and see if this fixes the issue?

Worked, thanks!
I din’t realise I did import data with wrong ownership.

Sorry for the late reply, forgot to submit…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.