Galaxy File Upload Stalling


I am having problems getting any data to upload to Galaxy on my VM. Have tried the direct upload from disk and via FTP. Have restarted Galaxy but this did not resolve the issue, I have admin rights for this instance. Any suggestions?




I’m going to need to know a bit more about this instance Matt - could you let me know its name, which site its running on and whether the upload starts and then fails or never starts at all?


They are on the Birmingham system, I say they as I have a few VMs, none of which allow me to upload, one of them is called “strep-seq”. Upload gets to 1 or 2% and then terminates with an error message “Failed: Upload request failed. (0)”.

A post on another forum suggests that this behaviour is a result of the upload form sending a message to the server and that message is not acknowledged, possibly due to an old version of Galaxy server installation?

Do you need any additional info? What would happen if I were to change the region?




Hi Matt - can you try the instructions that I wrote here and here for file transfer to Galaxy via FTP connection please?

Permanently opening port 21 isn’t a great idea, so you probably want to remove the rule once you’ve finished uploading.


Funnily enough, I cannot log onto Horizon currently, 408 Request Time-out. Tried multiple machines to log in.



408 errors do suggest a browser problem, and we haven’t seen any issues our side. If you’ve tested multiple machines using the same upstream network connection or WiFi access point, they’ll probably suffer the same issue.

Perhaps try an ethernet connection instead?


Perfect, that seemed to be the issue. Any work around you can suggest so that I may be able to use wifi? I know this is probably outside your remit but worth a shot.

Cheers again.



Good question! Difficult one, because the easy answer is to (…constructively…) moan to your IT people or ISP until they sort you out a usable connection!

In the meantime, I’ll have a look at tweaking configs our side to make the webservers go a bit easier on slowly-responding connections…


Hmm, gives a nice excuse for not doing work at home… but I most certainly will be on to our IT department.