Genome-wide Association Studies (GWAS) - John Lees and Sam Sheppard

Try again on Warwick, should be good now!

Better. I can launch a server ok but now I’m getting prompted for a password? To confirm it should be:

ssh ubuntu@ipaddress
as the login and then it should automatically use the ssh key right? I managed a GVL without any issue.


I’ve just had a look at this instance and there’s definitely a key present, likely one you specified as the attached info looks similar to your username!

You can specify an ssh key using the -i flag with ssh, so:


Perfect! Worked a charm. Thanks for that.

The ssh command also automagically searches for keys in a hidden folder in your home directory named “.ssh”
(the preprended . hides it from the standard ls - list directory contents - command, you can see hidden files/folders with ls -a)

To be found by ssh, the filename of your key has to be id_rsa. If a file called id_rsa is found in the .ssh directory, its automatically tried first - no need to specify an identity (key) file with ssh -i.

If you’re into that kind of thing, you can observe the interaction between your client and the host (VM) if you add the -v (verbose) flag to your ssh command. So, with your key called id_rsa in the .ssh directory in your home directory, you can run:

to use your default key and work out exactly what’s happening (or going wrong!).

Cheers Matt, Thought i’d deleted the old ones but it turned out I had a second key in the known_hosts file that was causing the issue. Like the verbose flag, definitely into that sort of thing!
Thanks again!

I can’t even get the disc image to load. Any suggestions?



Hi Mark, can you explain a bit more about the behaviour you’re seeing and the steps I need to take to reproduce it?

With the settings as for below:

Nothing happens when I press the Launch Server button. Sometimes the graphic in the button spins thereafter, other times it spins once and then stops. Either way nothing else happens. I was able to get a GVL started but terminated it when I realised I needed the tutorial image.

I should add that I use Safari on a Mac. I tried Google Chrome in case it was a browser issue.


Great, thanks for the updated info Mark.

Based on the screenshot above, it looks like you haven’t created an SSH key for accessing your new instance. This goes in the final dropdown in the “Launch a custom server” dialog.

Thanks for bringing this to our attention, we’ll add some better signposting for this issue in Bryn shortly.

I noticed that there were no options in the “Server key name choice” other than ‘Make new key’. I would have expected it to flag up the fact that I needed to make a key (a help page?), or initiate the key creation process. I’ve noticed some posts about SSH keys elsewhere I’ll look there for guidance.

Many thanks

Right, so I’ve generated the SSH key successfully. How do I enter this into the dropdown in the “Launch a custom server” dialog. There is no text entry box to take the public key that I can find (either using safari or chrome). I’m sure I’m being thick so please forgive me if it is somewhere obvious that I haven’t spotted.

Ok, it appears to be a Mac problem. Just launched a Windows 10 VM and I get the appropriate text entry boxes which are missing in Safari and Chrome. Haven’t tried other browsers yet.

Have now tried Firefox. The SSH key text entry boxes appear on the webpage as they should with this browser. I have the problem on two separate Macs running different versions of the OS so I don’t think it is limited to a particular hardware or software combination.

Great everyting working fine (had to use the ssh {ip address} -i {key file} -l ubuntu to use SSH). Thank you for your patience. I can’t get a GVL dashboard for the instance (I just get an error). I’m not sure if this should happen or is just another Mac issue, but it didn’t prevent me using the tutorial.

Tutorial worked fine. I now wish to analyse my own data but find that fsm-lite is not installed on the image. I don’t suppose anyone has already compiled a copy to work on this image that I could use please.

Also for my data (271 Strep uberis genomes) I do have a phylogenetic tree providing the population structure (from Gubbins) do you have any advice as to how I’d use this to generate a distance matrix or should I just use the method in the tutorial? I’d be grateful for any advice. Thanks

You actually discovered a UI bug we inadvertently introduced when removing Nick’s SSH key as a default (we used this for the CLIMB launch).

We did some work behind the scenes to correct it last night, so hopefully you should be able to use Safari and Bryn to launch instances fine now.

The web pages that GVL serves actually take a little bit of time to initialize, and the whole GVL OS probably takes around an hour to unpack and install, so we recommend waiting a little while before using all of the features. SSH is part of the underlying OS, so it should be usable within the first couple of minutes of starting the instance.

You can check the progress of the OS booting and initializing in real-time via the advanced (Horizon) interface. Select the advanced interface from Bryn, log in, click Instances, then follow the instance name hyperlink. You can click the “Log” tab to view the boot sequence. When log shows “{instance name} login:”, you’ll be able to SSH in just fine.

This might be a bit of a moot point, as the GWAS tutorial is built on vanilla Ubuntu (16.04, I think) not GVL, so you don’t get the fancy web page and other GVL goodies.

Just checked. Safari works beautifully now.

Thanks for the feedback and apologies for the confusion!