Installing homebrew

I am trying to install homebrew on my Birmingham-based VM, and am having the following challenge. If I run:

/bin/bash -c "$(curl -fsSL"

I get asked for a password, and my normal password for VM access doesn’t work.
Thanks for any help!

try using sudo -l before executing the above command to make sure you have sudo access.

Thanks for the suggestion! However, unfortunately this seems to just print the installation script, but doesn’t actually run the installation.

Not on the same command line. As a command prior to running the homebrew installation script.

sudo -l (when typed alone as a command) shows you what sudo rights your account has. It should ask for your password (if you even know it - honestly, you shouldn’t for the ubuntu account that was put in by default)

if the NOPASSWD flag is set, it won’t even ask for your password. If you have no sudo rights, then you can’t install homebrew from that account.

I hope that clears it up a bit.


~~ Charles

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.