Installing qiime


I am having problems in installing qiime1. I installed miniconda and I created a qiime1 environment with all features of Qiime1. Everything seems to install ok with no errors or warning. However, when I give this command -t

I get this error:

ValueError: numpy.dtype has the wrong size, try recompiling

So, I tried to update numpy assuming that was the problem so It still didn’t work.

Can you please help me with this?

Using conda should prevent these kind of version problems! Can I just confirm that after installing qiime, you activated the qiime conda environment with:

source activate qiime1

and that you added miniconda to your PATH by adding to ~/.bashrc?

Prepending PATH=/home/<your_username>/miniconda/bin to PATH in /home/<your_username>/.bashrc

Thank you for your suggestion. When miniconda2 was installing, it asked if it should be added in your PATH and i said yes. So I assumed Miniconda was in my PATH, turns out it wasnt and that was the problem.



1 Like

Hello Matt

I am having another problem with PATH :frowning: Sorry for coming back on this.

I tried running which uses R packages such as MetagenomeSeq and CSS. I have installed these packages in the R environment of the server. However when I try to run python script, I get this error

Library optparse not found.

To install, open R and run the command:

If you already have the optparse package installed in a local directory,
please store the path to that directory in an environment variable
called “R_LIBRARY_PATH”. This may be necessary if you are running
QIIME on a cluster, and the cluster instances of R don’t know about
your local R libraries. If you don’t know your R library paths, you
can list them by opening R and running with the command, “.libPaths()”.
The current R instance knows about these paths:
[/home/linuxbrew/.linuxbrew/lib/R/3.4/site-library, /home/linuxbrew/.linuxbrew/Cellar/r/3.4.2/lib/R/library]

I see that R was probably installed using brew and the PATH for R is different from the library of R which is:

[1] “/usr/local/lib/R/site-library” “/usr/lib/R/site-library”
[3] “/usr/lib/R/library”

I would like to change the path of R so that it can detect ths site library since it has all the installed packages.

I have tried making an environment variable and it didnt work.

Could you please help me with this.



R is installed by both linuxbrew and from aptitude, and both installs have separate package libraries.

You should be able to make both installs see each-other’s libraries by adding the following line to your ~/.bashrc:

export R_LIBS=/usr/local/lib/R/site-library:/usr/lib/R/site-library:/usr/lib/R/library:/home/linuxbrew/.linuxbrew/lib/R/3.4/site-library:/home/linuxbrew/.linuxbrew/Cellar/r/3.4.1/lib/R/library

then making sure that you activate the new environment variable with:

source ~/.bashrc

Thank you so much Matt, it worked!

I really appreciate your help :slight_smile: