Issues with Prokka and Abricate

#1

Dear CLlMB team,

I’m having issues running Prokka and Abricate in my instance

*Prokka. Prokka (version 1.14.6) won’t finish running, even with default settings. It always stops at the same step:

[07:23:14] Running: cat PROKKA_07062020\/PROKKA_07062020\.IS\.tmp\.15990\.faa | parallel --gnu --plain -j 8 --block 874 --recstart '>' --pipe blastp -query - -db /home/linuxbrew/.linuxbrew/Cellar/prokka/1.14.6/db/kingdom/Bacteria/IS -evalue 1e-30 -qcov_hsp_perc 90 -num_threads 1 -num_descriptions 1 -num_alignments 1 -seg no > PROKKA_07062020\/PROKKA_07062020\.IS\.tmp\.15990\.blast 2> /dev/null

exiting with the following error:

[07:23:15] Could not run command: cat PROKKA_07062020\/PROKKA_07062020\.IS\.tmp\.15990\.faa | parallel --gnu --plain -j 8 --block 874 --recstart '>' --pipe blastp -query - -db /home/linuxbrew/.linuxbrew/Cellar/prokka/1.14.6/db/kingdom/Bacteria/IS -evalue 1e-30 -qcov_hsp_perc 90 -num_threads 1 -num_descriptions 1 -num_alignments 1 -seg no > PROKKA_07062020\/PROKKA_07062020\.IS\.tmp\.15990\.blast 2> /dev/null

Only these files are produced in the output directory:

$ ls PROKKA_07062020/ PROKKA_07062020.fna PROKKA_07062020.IS.tmp.17484.blast PROKKA_07062020.IS.tmp.17484.faa PROKKA_07062020.log

*Abricate. Abricate (version 1.0.0) fails running with the following error:

ERROR: BLAST database not found: /home/linuxbrew/.linuxbrew/Cellar/abricate/1.0.0/libexec/db/ncbi/sequences

Accordingly, the databases are not listed with abricate --list

DATABASE SEQUENCES DBTYPE DATE
ecoli_vf
megares
vfdb
resfinder
ecoh
plasmidfinder
argannot
ncbi
card

However, the database files are in the corresponding folder (I checked the “sequences” files and they seem to be alright):

$ ls /home/linuxbrew/.linuxbrew/Cellar/abricate/1.0.0/libexec/db/*
/home/linuxbrew/.linuxbrew/Cellar/abricate/1.0.0/libexec/db/abricate:
README

/home/linuxbrew/.linuxbrew/Cellar/abricate/1.0.0/libexec/db/argannot:
sequences sequences.ndb sequences.nhr sequences.nin sequences.not sequences.nsq sequences.ntf sequences.nto

/home/linuxbrew/.linuxbrew/Cellar/abricate/1.0.0/libexec/db/card:
sequences sequences.ndb sequences.nhr sequences.nin sequences.not sequences.nsq sequences.ntf sequences.nto

/home/linuxbrew/.linuxbrew/Cellar/abricate/1.0.0/libexec/db/ecoh:
sequences sequences.ndb sequences.nhr sequences.nin sequences.not sequences.nsq sequences.ntf sequences.nto

/home/linuxbrew/.linuxbrew/Cellar/abricate/1.0.0/libexec/db/ecoli_vf:
sequences sequences.ndb sequences.nhr sequences.nin sequences.not sequences.nsq sequences.ntf sequences.nto

/home/linuxbrew/.linuxbrew/Cellar/abricate/1.0.0/libexec/db/megares:
sequences sequences.ndb sequences.nhr sequences.nin sequences.not sequences.nsq sequences.ntf sequences.nto

/home/linuxbrew/.linuxbrew/Cellar/abricate/1.0.0/libexec/db/ncbi:
sequences sequences.ndb sequences.nhr sequences.nin sequences.not sequences.nsq sequences.ntf sequences.nto

/home/linuxbrew/.linuxbrew/Cellar/abricate/1.0.0/libexec/db/plasmidfinder:
sequences sequences.ndb sequences.nhr sequences.nin sequences.not sequences.nsq sequences.ntf sequences.nto

/home/linuxbrew/.linuxbrew/Cellar/abricate/1.0.0/libexec/db/resfinder:
sequences sequences.ndb sequences.nhr sequences.nin sequences.not sequences.nsq sequences.ntf sequences.nto

/home/linuxbrew/.linuxbrew/Cellar/abricate/1.0.0/libexec/db/vfdb:
sequences sequences.ndb sequences.nhr sequences.nin sequences.not sequences.nsq sequences.ntf sequences.nto

and reformating with abricate --setup is not solving the issue

*I’m working on a GVL, Ubuntu 16.04

Both programs were working fine until I upgraded to the latest version with brew so the issues may be related but I wouldn’t know how exactly

I hope you can help me to sort this out, I’d really appreciate it!

All the best,

closed #2

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

opened #3
#4

Hi,

I suspect the issue with Prokka is that you’re using an old version of parallel. Can you post the output of

which parallel
parallel --version

It’s strange that abricate can’t find the databases. I’ve just tested abricate 1.0.1 installed via brew and it’s working fine. Can you try upgrading abricate to version 1.0.1 and see if that solves the problem?

Best wishes,
Anna

#5

Hi Anna,

Thank you very much for the response. I upgraded abricate via brew as you suggested and version 1.0.1 is working now :slight_smile:, many thanks.

After this I tried running prokka again and it now works. I didn’t do anything else so probably upgrading abricate fixed an issue in common with prokka 1.14.6.

Almost all good now but am experiencing this issue: https://discourse.climb.ac.uk/t/rstudio-on-swansea-servers-blank-screen/1134 , with both RStudio and the SMRT portal; should I open a new issue for this?

Thanks again for all the help!

#6

Glad abricate and prokka are working! For RStudio, can you try running:

sudo rstudio-server restart

and see if that fixes it. If it still isn’t working, then can you post the output of the following:

sudo rstudio-server status
#7

I tried sudo rstudio-server restart but didn’t work: rsession: no process found

Here’s the output of status:

● rstudio-server.service - RStudio Server
Loaded: loaded (/etc/systemd/system/rstudio-server.service; enabled; vendor preset: enabled)
Active: active (running) since Tue 2020-08-04 07:54:51 UTC; 6s ago
Process: 29031 ExecStop=/usr/bin/killall -TERM rserver (code=exited, status=0/SUCCESS)
Process: 29034 ExecStart=/usr/lib/rstudio-server/bin/rserver (code=exited, status=0/SUCCESS)
Main PID: 29037 (rserver)
Tasks: 3
Memory: 852.0K
CPU: 1.888s
CGroup: /system.slice/rstudio-server.service
└─29037 /usr/lib/rstudio-server/bin/rserver
Aug 04 07:54:51 prophages-igh systemd[1]: Starting RStudio Server…
Aug 04 07:54:51 prophages-igh systemd[1]: Started RStudio Server.

#8

Hi
Can you try the following to fix Rstudio:

sudo systemctl stop nginx
sudo rm -rf /var/lib/nginx/proxy/
sudo systemctl start nginx

Radoslaw

#9

Hi,

I tried it, and it work brilliantly :slight_smile:

Thank you very much for the help!

Very best,