More space needed

Is it possible to increase space on my GVL? I am trying to generate fastq files from NextSeq bcl files and while it generated some it then failed due to lack of space on the device.

We start all instances with a 120 Gb boot volume (drive) and suggest that people use additional volumes for working on data because, as you’ve found, this can fill up quite quickly with sequencing data etc.

You can attach a new volume to your GVL instance (the cloud equivalent of installing a new hard drive), and the process is described here: Creating and attaching volumes using Horizon.

Drop me a reply if you have any problems!

Thanks so much, naturally I have already fallen at a hurdle…I only have “gpfs” as an option for volume type

No problem - the tutorial is a little incomplete here. We use two different storage types across the CLIMB sites, GPFS (at Birmingham, Warwick and Cardiff) and Ceph (at Warwick and Cardiff). If your instance is at Birmingham (it is!), you can only pick GPFS as a volume type, which is fine - just continue the guide from here.

Thanks I realized a few differences and have managed to attach the volume to the gvl I wanted however the format and mounting is now causing issues.
sudo fdisk /dev/vda tells me user galaxy is not allowed to execute…
Also tried Nicks alternative without using fdisk and that wasn’t allowed either!
Not doing too well here haha

Actually got past that to my /dev/vda is in use by the system and won’t make a filesystem here

The galaxy user does not have the privileges to use the sudo superuser. In order to partition, format and mount the attached volume, you will need to login with the “ubuntu” user, which does have the ability to use sudo. The ubuntu user will have the same password as the one you set your GVL instance up with (unless you’ve subsequently changed it).

You can use the lsblk command to list block devices connected to the instance, along with their mount points. You’ll see the device names like /dev/vda, /dev/vdb, and where they’re mounted (your newly attached volume won’t be mounted anywhere).

I’m having issues attaching a volume for data to my instances running on the Birmingham servers. I can create and attach a cephs drive to my instance (gpfs option does not work, even though I’m on the Bham cluster), but when I try the formatting, I get the following error:

sudo fdisk /dev/vde

Welcome to fdisk (util-linux 2.27.1).
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.

fdisk: cannot open /dev/vde: No such file or directory

I’ve also tried Nick’s shortcut, but I essentially get the same thing:

sudo mkfs -t ext4 /dev/vde
mke2fs 1.42.13 (17-May-2015)
The file /dev/vde does not exist and no size was specified.

The path is correct according to OpenStack, but I’m wondering if there’s something I;'m missing?
Thanks for any help.

Hi Paul,
We’ve fixed this, it was something we missed when we were bringing all of the kit back from the shutdown yesterday, but it should all be working now.

The ideal fix is to terminate the VM, delete the volume and then try again.

You can check what device (/dev/vd(a|b|c) your newly attached volume is from inside your VM using the command:


Thanks for your help. All sorted now.

1 Like