Nullarbor installation on GVL Cardiff Climb Snippy output no SNPs


#1

I created GVL climb server from the Cardiff cloud system with Nullarbor pipeline already configured, however, When I executed nullarbor pipeline on more than 200 isolates whole genomes fastq files and notice two errors.
First, snippy tool in the pipeline did not detect any SNPs in any of the isolates. I tried using three different reference genomes(FM211187, ATCC_700669, tigre4) but the ouput was the same, no SNP was detected by snippy in the nullarboe pipeline. I upgraded brew and updated all the nullabor tools in the pipeline but could not get any SNPs
Secondly, tbl2san error below is the error Could not run command: tbl2asn -V b -a r10k -l paired-ends -M n -N 1 -y ‘Annotated using prokka 1.12 from https://github.com/tseemann/prokka’ -Z ERR1065578/prokka/ERR1065578.err -i ERR1065578/prokka/ERR1065578.fsa
I tried the solution suggested in the community issues by still getting the same error
Please any help to will be very much welcome

regards
Archie


#2

Please could you paste snps.log from one of the samples to help establish what the problem is?


The tbl2asn problem is an unfortunate mismatch between NCBI’s licensing and the way that brew works. I suggest you install your own, system copy of tbl2asn following these steps:

brew remove --ignore-dependencies tbl2asn
wget https://ftp.ncbi.nih.gov/toolbox/ncbi_tools/converters/by_program/tbl2asn/linux64.tbl2asn.gz
gzip -d linux64.tbl2asn.gz
sudo mv linux64.tbl2asn /usr/local/bin/tbl2asn
sudo chmod +x /usr/local/bin/tbl2asn


#3

Bellow is the snp.log from snippy

samtools faidx reference/ref.fa

bwa index reference/ref.fa

[bwa_index] Pack FASTA… 0.07 sec
[bwa_index] Construct BWT for the packed sequence…
[bwa_index] 1.85 seconds elapse.
[bwa_index] Update BWT… 0.03 sec
[bwa_index] Pack forward-only FASTA… 0.04 sec
[bwa_index] Construct SA from BWT and Occ… 0.58 sec
[main] Version: 0.7.16a-r1181
[main] CMD: bwa index reference/ref.fa
[main] Real time: 2.794 sec; CPU: 2.572 sec

mkdir reference/genomes && cp -f reference/ref.fa reference/genomes/ref.fa

mkdir reference/ref && bgzip -c reference/ref.gff > reference/ref/genes.gff.gz

snpEff build -c reference/snpeff.config -dataDir . -gff3 ref

WARNING: All frames are zero! This seems rather odd, please check that ‘frame’ information in your ‘genes’ file is accurate.

(bwa mem -v 2 -M -R ‘@RG ID:snps SM:snps’ -t 4 reference/ref.fa /home/ubuntu/mrc_data/nullarbor_out/ERR1065578/R1.fq.gz /home/ubuntu/mrc_data/nullarbor_out/ERR1065578/R2.fq.gz | samtools view -@ 4 -F 3844 -q 60 -S -b -u -T reference/ref.fa - | samtools sort -O bam -o snps.bam -@ 4 -)

[E::bwa_set_rg] the read group line contained literal characters – replace with escaped tabs: \t

samtools index snps.bam

samtools depth -q 20 snps.bam | bgzip > snps.depth.gz

tabix -s 1 -b 2 -e 2 snps.depth.gz

fasta_generate_regions.py reference/ref.fa.fai 136117 > reference/ref.txt

freebayes-parallel reference/ref.txt 4 -p 1 -q 20 -m 60 --min-coverage 10 -V -f reference/ref.fa snps.bam > snps.raw.vcf

/home/linuxbrew/.linuxbrew/Cellar/snippy/3.1/bin/snippy-vcf_filter --minqual 10 --mincov 10 --minfrac 0.9 snps.raw.vcf > snps.filt.vcf

Parsing: snps.raw.vcf
No variants found.

snpEff ann -no-downstream -no-upstream -no-intergenic -no-utr -c reference/snpeff.config -dataDir . -noStats ref snps.filt.vcf > snps.vcf

bgzip -c snps.vcf > snps.vcf.gz

tabix -p vcf snps.vcf.gz

/home/linuxbrew/.linuxbrew/Cellar/snippy/3.1/bin/snippy-vcf_to_tab --gff reference/ref.gff --ref reference/ref.fa --vcf snps.vcf > snps.tab

Loading reference: reference/ref.fa
Loaded 1 sequences.
Loading features: reference/ref.gff
Parsing variants: snps.vcf
Converted 0 SNPs to TAB format.

vcf-consensus snps.vcf.gz < reference/ref.fa > snps.consensus.fa

/home/linuxbrew/.linuxbrew/Cellar/snippy/3.1/bin/snippy-vcf_filter --subs snps.filt.vcf > snps.filt.subs.vcf

Parsing: snps.filt.vcf
No variants found.

bgzip -c snps.filt.subs.vcf > snps.filt.subs.vcf.gz

tabix -p vcf snps.filt.subs.vcf.gz

vcf-consensus snps.filt.subs.vcf.gz < reference/ref.fa > snps.consensus.subs.fa


#4

The problem is this line:

[E::bwa_set_rg] the read group line contained literal characters – replace with escaped tabs: \t

BWA 0.7.16a-r1181 caused a problem with the way that snippy assigns read groups. This has been fixed in the snippy GitHub version.

You can get the latest commits with:

brew unlink snippy
brew install snippy --HEAD


#5

I am having challenges running Nullarbor on my VM which I set up on Cardiff server last week, 14Dec2017. When I type in “nullarbor.pl –h’ I get the error message

“read_dir ‘/home/linuxbrew/ .linuxbrew/bin/ …/plguins’ – opendir: No such file or directory at /home/linuxbrew/ .linuxbrew/Cellar/nullarbor/HEAD-1495981/bin/ …/per15/Nullarbor/Plugins.pm line 20”.

I feel that nullarbor is not properly installed.

I am unsure what I’m doing wrong. Can you please help?


#6

There’s been a bugfix for this problem that will be coming in Nullarbor v1.5 (https://github.com/tseemann/nullarbor/milestone/1)

You can patch this yourself by changing the following file:

/home/linuxbrew/.linuxbrew/Cellar/nullarbor/HEAD-1495981/perl5/Nullarbor/Plugins.pm

Line 10 from:

my $RUNNER_DIR = "$FindBin::Bin/../plugins";

to

my $RUNNER_DIR = "$FindBin::RealBin/../plugins";


#7

Hi @mattbull,

I’m having the same issue, yet, I couldn’t solve it. I unlinked snippy but couldn’t install it again: Here are the last lines I get from:

==> Installing snippy from tseemann/bioinformatics-linux
Error: No available formula with the name "vcflib" (dependency of tseemann/bioinformatics-linux/snippy)
==> Searching for a previously deleted formula (in the last month)...
Warning: homebrew/core is shallow clone. To get complete history run:
  git -C "$(brew --repo homebrew/core)" fetch --unshallow

Error: No previously deleted formula found.
==> Searching for similarly named formulae...
==> Searching local taps...
Error: No similarly named formulae found.
==> Searching taps...
==> Searching taps on GitHub...
Error: No formulae found in taps.

#8

This is down to the closing down and subsequent migration of formulae from homebrew/science. You can read about it here.

There will be a transition period where the commonly used homebrew formulae are migrated to homebrew/core and are unavailable.

Fortunately, thanks to the efforts of people like Shaun Jackman and Torsten Seemann, the old repos have been saved from the scrapheap and made available here and here.

You can access these kegs by tapping them:

brew tap brewsci/homebrew-bio
brew tap brewsci/homebrew-science

After you’ve tapped these kegs, you should be able to

brew install snippy --HEAD

While these repos will provide packages, they do so without any maintenance, except to migrate packages to homebrew/core.


#9

Thank you very much for the reply and the information @mattbull.

Tapping the kegs worked. Snippy is installed and working (calling variants).