Permission denied (publickey, password)

#1

Please, help resolve following problem: I cannot SSH (or use cyberduck) to access my CLIMB account, I can only log in to bryn.

First, when trying to ssh simply with ssh ubuntu@my address I get “Permission denied, please try again”, after 3 times it changes to “Permission denied (publickey, password)”

This happens on different devices.

I have seen the Ssh "Permission Denied (publickey)" all of the sudden! thread here, but I believe if I cannot log in, I cannot do anything anyway (if it is in the thread listed reason 3. or 4.) and I am far from fluent in commandline stuff at the moment.

My operation system is Windows 10 and I am using Bash on Ubuntu on Windows

Many thanks in advance,

Dagnija

#2

Hi Dagnija,

A few questions:

  1. Have you accessed CLIMB previously using this method?
  2. Are the instances GVL instances?
  3. Have you modified any permissions on your local machine or on the cloud instances?
  4. Have you tried a ssh client for windows such as putty?

All the best,
Sion

#3

Hi Sion,

I have logged in on CLIMB the same way at least 15 times before, including the day it stopped working. I have not changed anything as far as I can tell. Unfortunately I do not know what GVL instances are, so I cannot answer that question. I briefly had putty toghether with Cygwin on a Windows 7 computer, but these worked poorly (on Cygwin part likely). Using Bash on Ubuntu on Windows was recommended by my colleague as the best and had worked fine so far. Currently I do not have anyone around who could help me set up putty.

Best regards,
Dagnija

#4

Hi Dagnija,

Genome Virtual Laboratory (GVL) are the basic instances that are created using Bryn. You can select your instance type via the Bryn dashboard.

To determine the source of your issue we will need to go through a few steps.

1/ Could you try restarting your instance and try logging in again.
2/ Try connecting to another instance using your current method (perhaps a colleague’s instance)
2/ Finally, could you try connecting to your instance using putty.

This final step will allow us to determine if your issue is on the server or your local computer. Here is a basic tutorial - https://mediatemple.net/community/products/dv/204404604/using-ssh-in-putty-.

All the best,
Sion

#5

Hi Sion,

My supervisor rebooted my account a day before I submitted the question and it did not help.
I have tried to ssh the same way from a borrowed Mac and it did not work as well (so I do not think it is a Windows/putty issue).
I am not running any of the tools on CLIMB, I am just storing data there at the moment. Getting the same error as before.

Best regards,
Dagnija

#6

P.S. I tried to use the Lubuntu, which is the only isntance I have tried to use so far, and assuming that I correctly understand that “cluster password” is the same password I log in to my account, and it does not work.

#7

Hi Dagnija,

Could you PM me to IP address of the instance, the site it is located and your group name (at the top of the Bryn page). I will pass the request onto the site admin and see if it is an issue with the instance.

All the best,
Sion

#8

Hi Dagnija,

We have confirmed that there is nothing wrong with the instance. You are likely to be attempting to use your group password (for logging into Bryn) to access the instance. There is a password for each instance separate from the group password. Whoever created the instance will have set a password for it and can provide you with access.

All the best,
Sion

#9

Hi Sion,

Thank you for checking. I was trying to ssh into my own instance using by own password when I first got the error. I did change my bryn password after this original error, and that works for loggin in onto my bryn account, but I still can’t access my instance through ssh. I was the one that set up the orgincal instance and my own password. Could it be that because of too many failed attempts I am logged out of the account and the password needs re-settting? As I said above I can’t log in lubuntu or R studio etc. I had someone else use my computer to ssh into their own instance (in the same group) and that worked so there is nothing obviously wring with my local computer set up.

Thanks for your help,
Dagnija

#10

Hi Dagnija,

Your instance is not linked to your bryn password or bryn account in any way once the instance has been launched. Try using the original password that you set when you created the instance.

All the best,
Sion

closed #11

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.