Problem with running Snippy

Please use this template to help us fix your problem quickly! Please don’t include sensitive information (including IP addresses) and fill in sections as appropriate.

CLIMB SERVICE PROBLEMS (Bryn, OpenStack, Launching VMs, Creating and attaching Volumes, etc.)

1. Describe the problem. Are there any error messages you can paste? Can you provide a screenshot of the problem (with sensitive information removed)?

**_Hello, I was trying to run snippy on my server, but I get a warning “MSG: Got a sequence without letters. Could not guess alphabet”.

I ran snippy in the past on this server without any problems. When I tried to update it to the latest version, I got another error message:

" Error: Checksum mismatch.

Expected: 9df214085a0e566a580eea3dd9eab14a2a94930ff74fbf97fb1284e905c8921d

Actual: cc027e32fc7ca4212e3b1f64a649c447dc526eec6af3a037da436f0a2ffe0106

Archive: /mnt/gvl/tmp/homebrew_cache/portable-ruby-2.3.7.x86_64_linux.bottle.tar.gz

To retry an incomplete download, remove the file above.

Error: Failed to upgrade vendor Ruby.

/home/linuxbrew/.linuxbrew/Library/Homebrew/brew.rb:12:in `<main>’: Homebrew must be run under Ruby 2.3! You’re running 2.0.0. (RuntimeError)."

Then I tried to update Ruby and got another error message
“ubuntu@salmonellaevolutionsequencing:~$ sudo apt-get install ruby2.2-dev
E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.
ubuntu@salmonellaevolutionsequencing:~$ sudo apt-get install ruby2.2”.

And when I tried to run the sudo dpkg it said "dpkg: dependency problems prevent configuration of cups:
cups depends on cups-server-common (>= 2.1.3-4ubuntu0.5); however:
Version of cups-server-common on system is 2.1.3-4ubuntu0.4.

dpkg: error processing package cups (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:

2. What is the name of the VM or volume that the problem is affecting?
3. Where is the VM or volume hosted; Birmingham, Cardiff, Swansea or Warwick?
4. Is there any other information that you think might be helpful?
I tried running snippy on new data but also in old data that has worked in the past, in both cases unsuccessfully. When my colleague ran snippy for a couple of my samples in her VM it worked without any problems.

SOFTWARE OR APPLICATION PROBLEMS (Python can’t find the modules I installed, Prokka doesn’t predict any ORFs, etc.)

1. Describe the problem. Include links to any guides that you might be following and a brief history of the commands that you’ve run. Paste any error messages in code-blocks (paste, highlight and press Ctrl+Shift+C).

2. What operating system are you running; GVL, Ubuntu 16.04, Centos 7, etc.?

3. Is there any other information that you think might be helpful?


The GVL you are running might be an older version. Could you try running snippy on your data from the new GVL instance and see if this resolves the problem.

All the best,

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.