Problmes running CheckM on custom VM despite success in the past


#1

I have installed CheckM (checkm-genome: https://github.com/Ecogenomics/CheckM/wiki) on a custom VM (hosted at Swansea), making sure to install dependencies (covered by installing with pip) and downloading the required data files as per the installation instructions on the software wiki. However when I try and run it, I get the same error:

IOError: [Errno 2] No such file or directory: u’/home/ubuntu/maxbin/hmms/phylo.hmm’

The code I am trying t run has worked for me before, on climb, using the following command:

checkm lineage_wf -t 8 -x fasta /home/ubuntu/maxbin/103_L5 /home/ubuntu/maxbin/103_L5/checkm

The error message shorts the pipeline so the analysis starts but doesn’t complete, and the outputted files are useless.

Any help on what I might be able to do to solve this problem is much appreciated!


#2

This looks like an installation problem with checkM similar to the one described here - https://github.com/Ecogenomics/CheckM/issues/72

You might want to see if the fix described there works for you.


#3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.