Roary problem - Can't locate Bio/Roary/CommandLine/Roary.pm in @INC


#1

Hi, out of the blue, when I run roary I get this message.

Can’t locate Bio/Roary/CommandLine/Roary.pm in @INC (you may need to install the Bio::Roary::CommandLine::Roary module) (@INC contains: /home/ubuntu/lib /home/linuxbrew/.linuxbrew/Cellar/perl/5.28.1/lib/perl5/site_perl/5.28.1/x86_64-linux-thread-multi /home/linuxbrew/.linuxbrew/Cellar/perl/5.28.1/lib/perl5/site_perl/5.28.1 /home/linuxbrew/.linuxbrew/Cellar/perl/5.28.1/lib/perl5/5.28.1/x86_64-linux-thread-multi /home/linuxbrew/.linuxbrew/Cellar/perl/5.28.1/lib/perl5/5.28.1 /home/linuxbrew/.linuxbrew/lib/perl5/site_perl/5.28.1/x86_64-linux-thread-multi /home/linuxbrew/.linuxbrew/lib/perl5/site_perl/5.28.1) at /usr/local/bin/roary line 12.
BEGIN failed–compilation aborted at /usr/local/bin/roary line 12.

I tried everything, reinstalling bio::roary with cpan, via miniconda, nothing works. It was working fine yesterday.

Can you please help?

Andrea


#2

Try using cpanm via brew:

brew install cpanm
cpanm Bio::Roary


#3

I tried that, and it failed some of the checks at the end anyway and refused to install.
I solved with
cpan -f Bio::Roary
Apparently the -f option installs the module even if there are problems. I’ll check some of the output, otherwise I’ll just restart an new instance and take it from there. On my other instances it works fine…
Thank you!
Andrea


#4

Great!

Apologies for missing the -f - looks like even the developers don’t expect it to pass the unit tests!


#5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.