RStudio not reachable after unshelving

To Whom It May Concern:

*1. RStudio not reachable after unshelving. I have unshelved my Cardiff VM and everything seems to be working correctly (SSH, Juypter, Lubuntu, public HTML), except RStudio. It was working as recently as last Thursday, before the maintenance; however, I was not able to reach it today. The address seems completely non-responsive as I am not promoted for Username/password. The data under that partition is visible through the commandline.

*2. climb3

*3. Cardiff

Thank you for your assistance.


Hi Chris,

Can you try running:

sudo rstudio-server restart

and see if that fixes it. If it still isn’t working, then can you post the output of the following:

sudo rstudio-server status

Best wishes,


I will try this when the Cardiff region is back online. It is still unreachable when I tried 15 minutes ago.



I unshelved my instance (with everything booting/mounting fine) and tried the first command. It did not fix it. I ran the status command and received this output:

rstudio-server.service - RStudio Server
Loaded: loaded (/etc/systemd/system/rstudio-server.service; enabled; vendor preset: enabled)
Active: active (running) since Tue 2020-08-11 10:05:42 UTC; 16s ago
Process: 21172 ExecStop=/usr/bin/killall -TERM rserver (code=exited, status=0/SUCCESS)
Process: 21176 ExecStart=/usr/lib/rstudio-server/bin/rserver (code=exited, status=0/SUCCESS)
Main PID: 21177 (rserver)
Tasks: 3
Memory: 3.2M
CPU: 2.146s
CGroup: /system.slice/rstudio-server.service
└─21177 /usr/lib/rstudio-server/bin/rserver

Aug 11 10:05:42 climb3 systemd[1]: Starting RStudio Server…
Aug 11 10:05:42 climb3 systemd[1]: Started RStudio Server.

The restart command sends back: “rsession: no process found”

My other applications; Jupyter, Public HTML; are all still fine.

Suggestions for how to move on from here?


Hi Chris,

Can you run the following:

sudo systemctl stop nginx
sudo rm -rf /var/lib/nginx/proxy/
sudo systemctl start nginx

and see if that fixes RStudio

Best wishes,

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.