Touble launchin Beast

I am trying to use Beast through the ubuntu command line, I installed it using
sudo apt-get install beast

the installation seemed to go smoothly however when I try to use beast I get the following error:

(beast-0.7.8:29691): Gtk-WARNING **: cannot open display:

I have tried launching this both from my mac terminal and also using MobaXterm on a windows machine

any suggestions to get this up and running?


Hi Cat - the reason you’re seeing this error is because BEAST is graphical program (or at least opens a graphical window to select the .xml file for analysis). SSH-ing to your instance means that, by default, there isn’t a display connected to the terminal you’re working on, so there’s no display to send this window to, hence the error message.

You can make your instance forward graphics to your local display (i.e. your local monitor) by using the -X (forward X11) and -C (enable compression) flags when SSHing from the mac terminal:

ssh -X -C username@<ip address>

or by ticking the “X11-forwarding” box in MobaXterm as described here:

This applies for every graphical program (ACT, Artemis, Beauti, Firefox, etc), but expect the graphics to be a bit clunky, because you’re having to move them across the Internet rather than the cable that connects your monitor directly to the computer.


Alternatively, you can skip the graphical bit altogether and just run:

./beast path_to_your_file.xml

and check

./beast -h

for more options

thanks for this, I tried both of the options for launching the GUI but they didnt work, however I noticed that I have a super old version installed so I will try with an updated one.

However I shall probably just use it without the graphical bit :smile:


Latest binaries are here:

You could always generate your beast .xml file with beauti locally, then upload the .xml(s) to your instance to work on with beast…