Unable to mount volume to instance


#1

Problem attaching volume

*1. Neither of my volumes will mount one of them is full of files so I do not wish to do anything destructive. I am receiving the error that i is the wrong file system. The volume sdb has been mounted numerous times before. The error is:

mount: wrong fs type, bad option, bad superblock on /dev/sdb,
missing codepage or helper program, or other error

*2. The instance is OralSciencegla and both attached volumes wont mount.

*3. The VM is hosted at Swansea


#2

Hi,

Sounds like filesystem corruption, you could have potentially lost all your data.

Mount the volume, run lsblk to confirm what it has shown up as and then trying running sudo e2fsck -nf /dev/sdXN (replacing X and N with whatever from lsblk.

If you paste the output of the e2fsck command here we might be able to tell you if data is recoverable.


#3

Hello, I am having problems to mount a new volume to VM. I am following the instructions, I create and attach the Volume (120Gb) to my instance, and it says it is attached to /dev/sdc on my VM. Nevertheless, when I use lsblk command, there is a sdc appears but the size doesn’t match with the volume created. Also, if I type: sudo mkfs.xfs /dev/sdc, I get the following message
mkfs.xfs: /dev/sdc appears to contain an existing filesystem (xfs).
mkfs.xfs: Use the -f option to force overwrite.
Could you please assist me on this?
Thank you


#4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.