Unable to transfer data to mounted volume


I have created a volume to keep my data in, and attached and mounted it in a directory on my VM (hosted at Swansea). The VM is called ‘standys’ and the volume is called ‘greenland’. I am trying to move files to this volume but permission is denied. Am I doing something wrong?


Probably just a permissions issue!

You can find your username with the command:


Then use the output of whoami to change the owner of the directory at which you mounted the volume to make sure its your user:

sudo chown -R [output_of_whoami]:[output_of_whoami] /path/to/your/mountpoint

I just tried that and got ‘Operation not permitted’ in response…

Oops, my mistake - make sure you prefix with sudo:

sudo chown -R [output_of_whoami]:[output_of_whoami] /path/to/your/mountpoint


Perfect, thanks! I am now able to upload data etc.

1 Like

I have a different problem relating to the same instance. I appear to have filled my root, so I can’t run any processes. The /dev/sda1 Filesystem (mounted at ‘/’) is at 100% capacity. I suspect this is because I have been installing quite a few software packages via miniconda, and even after I tried to deleting those that I no longer need they still sit in the root (I ran ‘du -h’ and got a VERY long list).

Is there a way to clear some space from /dev/sda1 so I can continue to use this instance, or it is a gonna?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.