Redirected to Apache2 Ubuntu Defult page

I’m trying to access my CLIMB server, but when I click on the IP address link I’m redirected to a page which is titled “Apache2 Ubuntu Default Page” which starts out with:

“It works!
This is the default welcome page used to test the correct operation of the Apache2 server after installation on Ubuntu systems. It is based on the equivalent page on Debian, from which the Ubuntu Apache packaging is derived. If you can read this page, it means that the Apache HTTP server installed at this site is working properly. You should replace this file (located at /var/www/html/index.html) before continuing to operate your HTTP server.
If you are a normal user of this web site and don’t know what this page is about, this probably means that the site is currently unavailable due to maintenance. If the problem persists, please contact the site’s administrator.”

I definitely fall into the category of “normal user who doesn’t know what this page is about”, but it’s been like this all week, and I was just wondering what is going on?

Any advice would be greatly appreciated!

Hi Michelle,

I’m really sorry about this. We recently discovered a problem with the way that the NGINX webserver was configured on GVL 4.2. We were able to quickly change the configuration, but this new configuration will only apply to new VMs launched after 15th of July.

If you frequently use the web services (RStudio, VNC, Cloudman) on GVL, the simplest remedy is to launch a new GVL using the updated configuration and delete your current one, after you’ve backed up any data of course.

If you just use the command line via SSH, everything on your instance will still work correctly, apart from the web page. You can continue to use the command line utilities on this instance, or use the command line to transfer any data to a new instance using scp or rsync, and then delete the old instance.

Apologies again for the inconvenience, and please drop me a line if anything is unclear, or if there’s anything we can do to help transfer you to a new instance.


Hi Matt,
I just want to give a heads up that I think this problem may have recurred. I have a VM that is doing this (after a reboot which I carried out because I couldn’t access the Lubuntu/VNC). No big problem as everything is working A OK with ssh.
This is my first post too - so I’d like to say a massive thank you for this resource - it’s really excellent.

Hi Ben - glad you’re finding CLIMB useful, always nice to hear!

Please could you run the following commands to stop and disable apache, then restart nginx:

sudo systemctl stop apache2
sudo systemctl disable apache2
sudo systemctl restart nginx

That should get your GVL webpage back and working.

Perfect - problem solved and the VNC is up and running too. many thanks! Ben

1 Like