Ssh connection time out


#1

gvl instance has been launched however when I try to ssh in the connection times out!
And if I try associating a floating IP I do not have any ports to link it to!
What’s going wrong? This is all on the Birmingham node


#2

Could you explain a bit more about what the problem is? Are you using https://bryn.climb.ac.uk to launch a GVL instance?

What is the output if you try to ssh in verbose mode using ssh -vv ?

There is no reason to do anything with floating ips - you should see that your instance has an external ip address. Adding floating ips can break routing and other things, so I suggest you try making a new instance using https://bryn.climb.ac.uk.


#3

If I try ssh -vv I get lots of errors to do with key_load_public and then the connection is closed

I was trying to launch through horizon as it wasn’t working through bryn but I was able to run an instance I had previously on the Warwick node yesterday from bryn


#4

Could you post what those error messages are, perhaps the last 5 lines of output? They might be helpful for diagnosing the problem.

I suspect though that this might have been caused by trying to add a floating ip to a running instance, which has broken its networking completely, so you will have to delete any instances you’ve tried to attach a floating ip to and start again.

What were the symptoms of Bryn not working?


#5

Thanks so much for all your help. It has magically all started working today on the Birmingham node so hopefully I’m all sorted now!
Thanks again


#6

Nice one, glad everything is working for you again!


#7

I’ve just launched an GVL from the Cardiff node and I’m unable to SSH to use it, as the connection times out. I tried ssh -vv and got the following message:

OpenSSH_7.1p2, OpenSSL 1.0.1g 7 Apr 2014
debug1: Reading configuration data /etc/ssh_config
debug2: ssh_connect: needpriv 0
debug1: Connecting to 131.251.130.133 [131.251.130.133] port 22.
debug1: connect to address 131.251.130.133 port 22: Connection timed out
ssh: connect to host 131.251.130.133 port 22: Connection timed out


#8

Oops, my mistake!

This should be fixed now, please let me know if you have any more problems.


#9

Yep all working fine now. thanks!


#10

Hello, I also think i’m having the same problem. Have just launched an GVL from the Birmingham Node and as with the above i am unable to SSH to use it, due to the connection timing out. I have tried the ssh -vv and I receive this message :

OpenSSH_6.9p1, LibreSSL 2.1.8
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 21: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to 147.188.173.253 [147.188.173.253] port 22.
debug1: connect to address 147.188.173.253 port 22: Operation timed out
ssh: connect to host 147.188.173.253 port 22: Operation timed out


#11

I’m looking into this for you, I’ll update you as soon as I have more information.


#12

We’ve had a quick firewall rejig and this should be fixed now, apologies for the inconvenience!


#13

All sorted, Thank you very much